HMH/Ed for Kingsfield and Pensacola Beach
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Sep 28, 2021 - 07:06 CDT
Investigating
We are currently working with HMH/ED for Kingsfield Elementary and Pensacola Beach. They are currently not being imported at this time. We will update this page and individual support tickets once we have an update. (jsz)
Posted Aug 27, 2021 - 15:43 CDT
This incident affected: Teacher Tools (Other Teacher Tools) and Student Tools (HMH Instructional Materials).