New website experiencing difficulties

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 10:19 CDT

Investigating

The new District website has been experiencing technical issues. We are in communication with Finalsite to address the problems. - JW
Posted Oct 01, 2025 - 10:01 CDT
This incident affected: Other.