Focus Kiosk Error
Incident Report for Escambia County Public Schools
Resolved
This issue has been resolved. - JE
Posted Jan 26, 2021 - 08:58 CST
Investigating
The Focus team is currently investigating an error on the Focus Kiosks; the error states "There are no active school periods at this time."
Posted Jan 05, 2021 - 09:15 CST
This incident affected: Teacher Tools (Focus).