Canvas Quizzes issue

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 09:58 CDT

Update

We are continuing to investigate this issue.
Posted Mar 31, 2026 - 09:58 CDT

Investigating

Canvas Quizzes may not be not working at this time. Instructure is currently working to resolve the issue. - Canvas Team
Posted Mar 30, 2026 - 10:41 CDT
This incident affected: Teacher Tools (Canvas).