Pine Meadow Elementary-Phone Lines Are down
Incident Report for Escambia County Public Schools
Resolved
Phone service has now been restored to Pine Meadow Elementary. They can now make and receive calls.

~rm
Posted Sep 13, 2018 - 09:08 CDT
Identified
The problem has been identified and we have contacted the vendor for repair.
Posted Sep 12, 2018 - 08:12 CDT
Investigating
Pine Meadow is currently unable to make or receive phone or fax calls. We are investigating the issue.
Posted Sep 12, 2018 - 07:21 CDT