As of this morning, Wednesday, May 13th, Canvas and Mastery Connect are fully operational. The sync with Focus has been restored as of this morning. Please note that due to the high volume, the passback process may be slower than usual. We are continuing to monitor Canvas and will communicate if any adjustments are needed.
Posted May 13, 2026 - 14:23 CDT
Update
We are continuing to work with Instructure and monitor Canvas for issues. -JB
Posted May 12, 2026 - 11:53 CDT
Update
Canvas remains up thus far. Grade passback has been disabled as a precautionary measure. We will continue to monitor the situation.
Posted May 08, 2026 - 07:12 CDT
Monitoring
As of 10:30pm Canvas is up. We will continue to monitor the situation. Staff should be prepared to work without Canvas should it go down again. -JB
Posted May 07, 2026 - 22:46 CDT
Investigating
Canvas is currently unavailable. District staff members are reaching out to the vendor (TI).
Posted May 07, 2026 - 15:42 CDT
This incident affected: Student Tools (Other Student Tools).