DiscoveryEd - Teachers Can Not Access
Incident Report for Escambia County School District
Postmortem

IT staff reported this issue to Discovery Education, and Discovery Education resolved the issue with the way that the where processing the data that we were sharing with them.

Posted Aug 15, 2022 - 12:20 CDT

Resolved
Teachers should be able to login to DE.
Posted Aug 11, 2022 - 15:36 CDT
Investigating
Teachers currently can not access Discovery Education however, students can. We are working with DiscoveryED to resolve the issue.
Posted Aug 11, 2022 - 07:57 CDT
This incident affected: Student Tools (Discovery Education).