Reduced Internet Bandwidth

Incident Report for Escambia County Public Schools

Resolved

This incident has finally been resolved.
Posted Dec 09, 2025 - 08:41 CST

Identified

One of our Internet providers is having issues. We have routed around the problem and don't anticipate any user impact. -JB
Posted Dec 08, 2025 - 10:13 CST
This incident affected: Internet, Network, & Telephone (Internet).