Focus Running Slow
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Feb 29, 2024 - 16:07 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 29, 2024 - 11:01 CST
Investigating
We are experiencing an issue with Focus running slow at this time. This may affect Focus Kiosk also. We are working with the vendor on a resolution.
Posted Feb 29, 2024 - 08:19 CST
This incident affected: Teacher Tools (Focus).