Destiny - Performance Issues

Incident Report for Escambia County Public Schools

Resolved

Destiny should now be working normally.
Posted Aug 28, 2025 - 13:29 CDT

Investigating

We are currently experiencing performance issues which impact Destiny customers. We are aware of this issue and are working diligently to restore performance. We sincerely apologize for any inconvenience this has caused.
Posted Aug 28, 2025 - 11:02 CDT
This incident affected: Student Tools (Destiny).