Navigate 360 (Compass) issues

Incident Report for Escambia County Public Schools

Resolved

Navigate has resolved the issue. All schools should now be able to access the platform.
Posted Aug 19, 2026 - 15:56 CDT

Investigating

Navigate 360 (Compass) is currently unavailable for some schools. Navigate is currently working on their end for a resolution. We will provide updates as we receive them. - MM
Posted Aug 19, 2026 - 10:48 CDT
This incident affected: Teacher Tools (Other Teacher Tools).