Skyward access issues

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 07:24 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2026 - 07:23 CDT

Identified

The vendor has identified the cause and is working on a solution.
Posted Jul 16, 2026 - 11:57 CDT

Investigating

Skyward appears to be having issues preventing login. IT is aware and is investigating. -TB
Posted Jul 16, 2026 - 09:07 CDT
This incident affected: Finance Tools (Skyward - Finance).