Internet Issues

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 10:27 CDT

Investigating

We are investigating an issues impacting Internet performance. -JB
Posted Mar 25, 2026 - 09:03 CDT
This incident affected: Internet, Network, & Telephone (Internet).