Skyward Unavailable

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 14:20 CDT

Update

A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2026 - 12:36 CDT

Monitoring

Service has been restored - we are monitoring.
Posted Apr 29, 2026 - 12:34 CDT

Investigating

We are opening an incident with the vendor. -JB
Posted Apr 29, 2026 - 12:15 CDT
This incident affected: Finance Tools (Skyward - Finance).