SummitK12 experiencing problems.

Incident Report for Escambia County Public Schools

Resolved

The vendor has resolved the issue.
Posted Oct 03, 2025 - 15:45 CDT

Investigating

Currently, users of SummitK12 can not access the platform. SummitK12 is working to resolve the issue - MM
Posted Oct 03, 2025 - 11:44 CDT
This incident affected: Teacher Tools (Other Teacher Tools).