Login issues with AR

Incident Report for Escambia County Public Schools

Resolved

Update: AR in RenPlace has been restored for those users who were affected. -Integrations/MM
Posted Mar 03, 2026 - 13:19 CST

Investigating

It has been reported that students can not access AR in RenPlace. We are investigating the issue with the vendor and will update you when this has been resolved. - Integrations/MM
Posted Mar 02, 2026 - 10:47 CST
This incident affected: Student Tools (Accelerated Reader, Renaissance Place).