Savvas Realize Access Issue
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Dec 14, 2021 - 13:57 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 08, 2021 - 10:25 CST
Update
Savvas is back up at this time.
We will be monitoring For the next 24 hours.
Posted Dec 07, 2021 - 16:23 CST
Investigating
Savvas Realize Access Issue
New incident: Investigating
Realize is currently unavailable, our team is reviewing the situation and working to resolve as quickly as possible.
Time posted
Dec 7, 10:45 EST
Posted Dec 07, 2021 - 09:50 CST
This incident affected: Teacher Tools (Other Teacher Tools) and Student Tools (Savvas Instructional Materials (Pearson Realize)).