Progress Learning - USA Test Prep
Incident Report for Escambia County School District
Resolved
This incident has been resolved.
Posted Sep 02, 2022 - 08:41 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 01, 2022 - 16:19 CDT
Update
We are continuing to work with vendor to resolve the last of these issues.
Posted Aug 24, 2022 - 10:42 CDT
Identified
We are working the vendor to correct any issues.
Posted Aug 16, 2022 - 14:21 CDT