Certiport testing issues

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 09:15 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2026 - 14:30 CDT

Identified

Certiport testing software is experiencing issues when administering exams. The vendor is working on a fix.
Posted Apr 28, 2026 - 14:37 CDT
This incident affected: Other.