PEER MAINTENANCE

Incident Report for Escambia County Public Schools

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2026 - 12:50 CDT

Investigating

PEER Users:

This is a reminder for tonight. On Wednesday, March 25, 2026, the Northwest Regional Data Center (NWRDC) will perform maintenance on PEER Production and other FDOE systems.

The maintenance window will begin at 6:00 PM ET and tentatively end at 9:00 PM ET. Users should save and close their applications before 6:00 PM ET, as FDOE systems are unavailable during the maintenance window. Thank you!
Posted Mar 25, 2026 - 12:48 CDT
This incident affects: Teacher Tools (PEER).