Kronos experiencing latency

Incident Report for Escambia County Public Schools

Monitoring

The vendor has implemented a fix. We are monitoring the results. If you are a Timekeeper or Supervisor who continues to experience latency while processing timesheets, please notify Anya Klinginsmith or Dasia Williams directly. Thank you.
Posted Jun 11, 2026 - 13:48 CDT

Update

"The vendor is still working on the issue. In the meantime, if you are a Timekeeper or Supervisor still experiencing latency while processing timesheets, please notify Anya Klinginsmith or Dasia Williams directly. Thank you." - AK
Posted Jun 04, 2026 - 12:59 CDT

Identified

"Timekeepers and Supervisors may be experiencing latency when processing timesheets. Kronos has been made aware and updates will be posted as available. We apologize for any inconvenience. Thank you. - AK"
Posted Jun 01, 2026 - 09:30 CDT
This incident affects: Finance Tools (Kronos).