Issues with PEER

Incident Report for Escambia County Public Schools

Monitoring

From FLDOE:

Good afternoon, PEER Users,

We would like to apologize for the PEER outage this morning, which began around 10:00 AM EST. We have been closely monitoring and working to resolve the issue, and as of 12:00 PM, the system has reached a stable state.

Our team will continue to monitor performance and respond as quickly as possible should any further issues arise. We sincerely apologize for the inconvenience and greatly appreciate your patience as we worked to resolve the problem.

Thank you for your understanding!
Posted May 18, 2026 - 12:08 CDT

Investigating

From FLDOE:
"We’re currently aware of the issue of accessing PEER and have submitted a ticket to get it resolved as soon as possible. We apologize for the inconvenience and appreciate your patience while we work to fix it quickly."
Posted May 18, 2026 - 09:59 CDT
This incident affects: Teacher Tools (PEER).