Core App Dashboard Down
Incident Report for Escambia County Public Schools
Resolved
The Core App Dashboard is now back up.

IT Integrations - MM
Posted Nov 12, 2024 - 11:53 CST
Investigating
The Core App Dashboard is currently down. We are working on a resolution.

IT Integration - MM
Posted Nov 12, 2024 - 10:52 CST
This incident affected: Other.