Powerschool (Talented) Professional Development System Unavailable - PJH

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 10:32 CST

Identified

This is a global issue - Powerschool's support team is working to resolve it as soon as possible.
Posted Feb 17, 2026 - 08:50 CST

Investigating

We are currently investigating this issue.
Posted Feb 17, 2026 - 08:40 CST
This incident affected: HR Tools (PowerSchool Products Performance Matters).