Internet Filtering Issues

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 08:25 CST

Investigating

We are currently investigating an issue where users are not receiving the correct filtering policies.
Posted Feb 02, 2026 - 11:01 CST
This incident affected: Internet, Network, & Telephone (Linewize, Internet).