Skyward outage

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 13:33 CDT

Monitoring

We believe this issue is resolved - we will continue to monitor
Posted Jul 28, 2025 - 12:19 CDT

Update

We are continuing to investigate this issue.
Posted Jul 28, 2025 - 11:58 CDT

Investigating

We are aware of an outage with Skyward, and are working with the vendor to resolve.
Posted Jul 28, 2025 - 11:53 CDT
This incident affected: Finance Tools (Skyward - Finance, Skyward PAC) and HR Tools (Skyward - HR).