District Web Site is Down
Incident Report for Escambia County School District
Resolved
This incident has been resolved.
Posted Apr 04, 2021 - 00:19 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2021 - 19:41 CDT
Investigating
Page results are blank. We are investigating. -JB
Posted Apr 03, 2021 - 18:47 CDT
This incident affected: Email, Calendar, & Collaboration (School Loop).