Google Captcha

Incident Report for Escambia County Public Schools

Monitoring

This issue seems to have been largely solved. We will monitor and update as needed.
Posted Apr 10, 2025 - 10:12 CDT

Update

This issue has been escalated within Google technical support.
Posted Apr 07, 2025 - 11:48 CDT

Investigating

We are working with Google to try to resolve the recurring issue of users being prompted to prove that they are not a robot. Most notably when trying to access Google Forms or Google Calendar. -JB
Posted Apr 04, 2025 - 10:14 CDT
This incident affects: Email, Calendar, & Collaboration (Google Apps Calendar).