Google Calendar Showing Captcha

Incident Report for Escambia County Public Schools

Investigating

We seem to back to square one on this issue. We continue to work with Google tech support in search of a resolution.
Posted Oct 22, 2025 - 12:17 CDT

Monitoring

Google has made some changes and this appears to be better. We are monitoring the results. -JB
Posted Oct 21, 2025 - 13:54 CDT

Update

We are continuing to pursue a resolution for this issue
Posted Sep 12, 2025 - 11:53 CDT

Update

We are continuing to pursue a resolution for this issue and have escalated it with Google support.
Posted Sep 04, 2025 - 13:28 CDT

Investigating

Many users are being shown captcha images in order to access Google Calendars. We have a ticket open with Google about the issue. -JB
Posted Aug 12, 2025 - 10:52 CDT
This incident affects: Email, Calendar, & Collaboration (Google Apps Calendar).