Ernest Ward Middle-Phone Lines are down.
Incident Report for Escambia County School District
Resolved
This incident has been resolved.
Posted Apr 12, 2021 - 13:38 CDT
Investigating
We are currently investigating this issue.
Posted Apr 12, 2021 - 08:00 CDT
This incident affected: Internet, Network, & Telephone (Telephones).