Cloudflare Global Network Experiencing Issues

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 10:53 CST

Monitoring

Cloudflare reports that they have implemented a fix for the issue.
Posted Nov 18, 2025 - 08:57 CST

Investigating

Cloudflare Global Network is experiencing issues that may impact certain websites from loading.
Posted Nov 18, 2025 - 07:34 CST
This incident affected: Internet, Network, & Telephone (Internet).