Reduced Internet Bandwidth
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Jan 04, 2024 - 20:51 CST
Identified
One of our internet providers is down. We are routing around the issue until it is resolved. We do not expect an impact to services. -JB
Posted Jan 04, 2024 - 17:41 CST
This incident affected: Internet, Network, & Telephone (Internet).