Google Classroom Experiencing Issues
Incident Report for Escambia County Public Schools
Resolved
Google reports this issue has been resolved. JB
Posted Apr 24, 2024 - 08:41 CDT
Investigating
This Apps outage alert is to inform you of a Google Workspace issue affecting some of the supported services.

The alert details include:

Status: Ongoing
Affected service: Classroom
Summary: Our team is continuing to investigate this issue.
Next update estimate: Tuesday, Apr 23, 2024, 4:00:00 PM (UTC).
Additional information is available on the Google Workspace Status Dashboard. -jsz & TD
Posted Apr 23, 2024 - 10:31 CDT
This incident affected: Teacher Tools (Other Teacher Tools).