System Outages

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 08:28 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2025 - 06:52 CDT

Investigating

Log in issues are affecting major systems. Network Services is investigating.
Posted Sep 11, 2025 - 06:45 CDT
This incident affected: Finance Tools (Skyward - Finance, Skyward PAC, Kronos).