Powerschool (Evaluations) unavailable

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 12:11 CDT

Investigating

We are unable to access Powerschool. We are working with the vendor to resolve.
Posted Jun 30, 2025 - 07:53 CDT
This incident affected: HR Tools (PowerSchool Products Performance Matters).