Some Users Cannot Reach Google Sites

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 14:32 CDT

Monitoring

The cause has been identified and we are monitoring the results. -JB
Posted Oct 02, 2025 - 13:27 CDT

Investigating

A subset of users cannot reach Google related sites. We are investigating this incident. -JB
Posted Oct 02, 2025 - 08:10 CDT
This incident affected: Email, Calendar, & Collaboration (Google Apps Gmail, Google Apps Calendar, Google Classroom, Google Apps Drive, Google Apps Docs, Google Apps Sheets, Google Apps Sites, Google Apps Slides, Google Meet).