Filr Unavailable

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted May 04, 2026 - 15:48 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 04, 2026 - 14:12 CDT

Update

We are continuing to work with OpenText on a solution.
Posted Apr 30, 2026 - 09:36 CDT

Investigating

We are investigating an issue with Filr.
Posted Apr 29, 2026 - 11:22 CDT
This incident affected: Email, Calendar, & Collaboration (FILR).