PowerSchool/TalentEd

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Nov 21, 2023 - 08:34 CST

Investigating

We are aware some users are receiving an error message when using the Professional Development Application. The vendor has been notified and we are waiting for their resolution. PJH
Posted Aug 24, 2023 - 09:52 CDT
This incident affected: HR Tools (PowerSchool Products Performance Matters).