Casting Services Down

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Jan 07, 2026 - 14:41 CST

Update

We are continuing to investigate this issue.
Posted Jan 07, 2026 - 10:56 CST

Investigating

We are currently experiencing issues with our casting services. We are looking in the issue. -jsz
Posted Jan 07, 2026 - 08:13 CST
This incident affected: Other.