We sincerely apologize for the ongoing challenges you’ve experienced with the PEER system. At 11:30 AM ET today, we implemented a configuration update in PEER Production aimed at improving system performance.
Please note that it may take several hours for these changes to fully take effect. If you continue to encounter issues, we recommend closing your browser and trying again.
Our team is actively monitoring the system to ensure stability and will provide additional updates as soon as new information becomes available. We cannot thank you enough for your patience, understanding, and perseverance during this very difficult time. Your commitment to your work despite these disruptions means so much to us.
With our deepest apologies,
The PEER Team
Posted Nov 17, 2025 - 11:34 CST
Update
Dear PEER Users,
We are profoundly sorry for the ongoing PEER system outage and the disruption it has caused to your work. We fully recognize how critical this application is to your daily responsibilities, and we deeply regret the challenges these interruptions have created. Please know that this situation weighs heavily on us.
Restoring full functionality remains our highest and most urgent priority. Our technical team is working around the clock, doing everything possible to identify and resolve the issue as quickly as humanly possible.
At this moment, we do not have a confirmed timeline for complete restoration, and we understand how frustrating that is. We promise to share updates with you immediately as soon as new information becomes available.
Thank you for your extraordinary patience, understanding, and continued dedication during this difficult time. Your commitment and resilience mean more to us than words can express.
With sincere apologies, The PEER Team - P.Farmer
Posted Nov 17, 2025 - 10:03 CST
Investigating
PEER is down again. PEER support is aware and working on the issues.