Focus - Unable to Generate/Print Forms from Student Info Pages
Incident Report for Escambia County School District
Resolved
This incident has been resolved.
Posted Jan 28, 2022 - 15:58 CST
Monitoring
The issue has been corrected and you can now generate your forms. We will continue to monitor the fix. - JE
Posted Jan 28, 2022 - 11:37 CST
Investigating
We are currently investigating why users are unable to generate forms and print them inside of Focus while on the Student Info pages. - JE
Posted Jan 28, 2022 - 08:41 CST
This incident affected: Teacher Tools (Focus).