Login issues reported for Navigate 360

Incident Report for Escambia County Public Schools

Resolved

Update: Navigate 360 has resolved the issue and users should now be able to access the platform -Integrations/MM
Posted Mar 03, 2026 - 13:18 CST

Identified

Update: Navigate 360 has discovered that the login issues we are seeing are on their side. They are working to get it resolved and will notify us when a resolution has been put in place. Integrations/MM
Posted Mar 02, 2026 - 11:48 CST

Investigating

It has been reported that users can not log into Navigate 360 (Compass). We are investigating the issue with the vendor and will let you know when things are resolved. - Integrations/MM
Posted Mar 02, 2026 - 10:46 CST
This incident affected: Student Tools (Other Student Tools).