Potential MFA Delays for T-Mobile Devices

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 12:18 CST

Investigating

From Twilio's status page. Twilio Incident - SMS Delivery Delays to T-Mobile Network. We are experiencing SMS delivery delays when sending messages to T-Mobile Network in United States of America. Our engineers are working with our carrier partner to resolve the issue.
Posted Nov 12, 2025 - 08:55 CST
This incident affected: Single Sign-on and User Management (Single Sign On / Authentication).