Phone Maintenance
Incident Report for Escambia County School District
Resolved
This incident has been resolved.
Posted Nov 29, 2021 - 08:49 CST
Investigating
Contractors are on site upgrading equipment. Phones will be down intermittently. Calls from McDaniel Building to Hall Center will need to use full phone number, extensions will be disabled. RHD
Posted Nov 22, 2021 - 08:19 CST
This incident affected: Internet, Network, & Telephone (Telephones).