Navigate EM Platform coming up blank

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 10:18 CDT

Investigating

Administrators are receiving a blank screen when logging into EM platform(Inside of Navigate). The vendor is aware of the issue and looking into it.
Posted Sep 16, 2025 - 11:24 CDT
This incident affected: Other.