Destiny

Incident Report for Escambia County Public Schools

Resolved

This access incident is reported as resolved.
Posted Aug 19, 2025 - 12:27 CDT

Investigating

We are currently experiencing issues which impacts the ability to access Destiny in a timely manner. We are aware of this issue and are working diligently to restore performance. We sincerely apologize for any inconvenience this has caused.
Posted Aug 18, 2025 - 11:43 CDT
This incident affected: Student Tools (Destiny).