Slowdown in Kronos

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 14:39 CDT

Investigating

We have alerted Kronos of difficulty accessing/retrieving information. Updates will be provided when known. - AK
Posted Jun 30, 2025 - 09:41 CDT
This incident affected: Finance Tools (Kronos).