PEER not responding.

Incident Report for Escambia County Public Schools

Resolved

PEER should be working normally at this time.
Posted Feb 10, 2026 - 11:38 CST

Investigating

PEER is having connection issues at this time; the vendor has been contacted and is reporting that they are aware of the problem, and are investigating.
Posted Feb 10, 2026 - 09:02 CST
This incident affected: Teacher Tools (PEER).