AWS Worldwide Outages
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Dec 08, 2021 - 10:25 CST
Update
Posted Dec 07, 2021 - 13:18 CST
Investigating
AWS Amazon Web Services is having major outages around the world today.
This will affect several applications.
Posted Dec 07, 2021 - 13:11 CST
This incident affected: Internet, Network, & Telephone (Internet).