Phone Service Outage for School District
Incident Report for Escambia County Public Schools
Resolved
Phone Service should now be restored across the district.
Posted Feb 09, 2024 - 11:32 CST
Investigating
We are currently experience a loss of phone service across the district. Please be patient with our team as they are working to address the issue.
Posted Feb 09, 2024 - 11:30 CST
This incident affected: Internet, Network, & Telephone (Telephones).